App Store Subscriptions Access Issue
Incident Report for RoverRadio
Resolved
A fix has been rolled out for this issue. It only affected some Android who subscribed to RMG Plus inside the app and were billed through Google Play. To correct, please delete the RoverRadio and re-install. Then follow the instructions located below to restore your Google Play subscription. https://support.roverradio.com/hc/en-us/articles/4406269534099-I-have-a-subscription-but-can-t-access-Plus-content
Posted Sep 03, 2024 - 14:39 EDT
Identified
The cause of the issue has been identified, and we are investigating possible solutions.
Posted Aug 29, 2024 - 08:16 EDT
Investigating
Some App Store-based subscriptions purchased inside the RoverRadio app (Apple App Store, Google Play, Roku, etc.) cannot access RMG Plus content. Subscriptions purchased directly through RoverRadio.com should function normally. We are investigating the issue and seek to implement a resolution as quickly as possible.
Posted Aug 26, 2024 - 21:04 EDT
This incident affected: RoverRadio App (Mobile App - iOS, Mobile App - Android, Mobile App - Amazon, Roku) and RMG Plus Subscriptions.